RFR: 8340141: C1: rework ciMethod::equals following 8338471 [v9]
Dean Long
dlong at openjdk.org
Tue Nov 26 17:21:15 UTC 2024
> This PR changes ciMethod::equals() to a special-purpose debug helper method for the one place in C1 that uses it in an assert. The reason why making it general purpose is difficult is because JVMTI can add and delete methods. See the bug report and JDK-8338471 for more details. I'm open to suggestions for a better name than equals_ignore_version().
>
> An alternative approach, which I think may actually be better, would be to check for old methods first, and bail out if we see any. Then we can change the assert back to how it was originally, using ==.
Dean Long has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 12 commits:
- redo without bailout
- Merge remote-tracking branch 'origin/master' into 8340141
- add missing bailout checks
- C1 fix
- remove blank line
- Merge master
- bail out on old methods
- redo VM state
- fix errors
- make sure to be in VM state when checking is_old
- ... and 2 more: https://git.openjdk.org/jdk/compare/4d4cef80...7a7bdb86
-------------
Changes: https://git.openjdk.org/jdk/pull/21148/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=21148&range=08
Stats: 40 lines in 3 files changed: 21 ins; 18 del; 1 mod
Patch: https://git.openjdk.org/jdk/pull/21148.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/21148/head:pull/21148
PR: https://git.openjdk.org/jdk/pull/21148
More information about the hotspot-compiler-dev
mailing list