RFR: 8330157: C2: Add a stress flag for bailouts [v12]

Daniel Skantz duke at openjdk.org
Fri Oct 4 14:25:45 UTC 2024


On Wed, 2 Oct 2024 11:55:42 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:

>> Daniel Skantz has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   left over
>
> src/hotspot/share/opto/compile.hpp line 838:
> 
>> 836:   const CompilationFailureInfo* first_failure_details() const { return _first_failure_details; }
>> 837: 
>> 838:   bool failing(DEBUG_ONLY(bool no_stress_bailout = false)) {
> 
> It's somehow difficult to read what `failing(false/true)` now exactly mean. When having `failing(true)`, don't we get the same behavior as if we call `failing_internal()`? If `failing_internal()` is false, then we would only return false because we are not entering
> 
>     if (StressBailout && !no_stress_bailout) {
>       return fail_randomly();
>     }
> 
> So, I'm wondering if we cannot just use `failing_internal()` instead of `failing(true)` and remove the parameter completely?

Thanks for the suggestions! Updated the PR.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/19646#discussion_r1787800936


More information about the hotspot-compiler-dev mailing list