RFR: 8340141: C1: rework ciMethod::equals following 8338471
Dean Long
dlong at openjdk.org
Tue Sep 24 00:40:52 UTC 2024
This PR changes ciMethod::equals() to a special-purpose debug helper method for the one place in C1 that uses it in an assert. The reason why making it general purpose is difficult is because JVMTI can add and delete methods. See the bug report and JDK-8338471 for more details. I'm open to suggestions for a better name than equals_ignore_version().
An alternative approach, which I think may actually be better, would be to check for old methods first, and bail out if we see any. Then we can change the assert back to how it was originally, using ==.
-------------
Commit messages:
- rename and restrict usage
Changes: https://git.openjdk.org/jdk/pull/21148/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=21148&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8340141
Stats: 19 lines in 3 files changed: 15 ins; 0 del; 4 mod
Patch: https://git.openjdk.org/jdk/pull/21148.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/21148/head:pull/21148
PR: https://git.openjdk.org/jdk/pull/21148
More information about the hotspot-compiler-dev
mailing list