RFR: 8340141: C1: rework ciMethod::equals following 8338471

Dean Long dlong at openjdk.org
Wed Sep 25 22:54:34 UTC 2024


On Wed, 25 Sep 2024 22:07:18 GMT, Vladimir Kozlov <kvn at openjdk.org> wrote:

>> This PR changes ciMethod::equals() to a special-purpose debug helper method for the one place in C1 that uses it in an assert.  The reason why making it general purpose is difficult is because JVMTI can add and delete methods.   See the bug report and JDK-8338471 for more details.  I'm open to suggestions for a better name than equals_ignore_version().
>> 
>> An alternative approach, which I think may actually be better, would be to check for old methods first, and bail out if we see any.  Then we can change the assert back to how it was originally, using ==.
>
> Instead of bailout in alternative approach we can change `cha_monomorphic_target` to `nullptr` in code which is looking for it in previous lines. `target` will be used for call  and we will loose a little performance when JVMTI is used instead of skipping compilation. Am I missing something?

@vnkozlov , I like the alternative approach better.  I went with the current approach because I was thinking it would be simpler than the bailout, but I changed my mind after writing both out.

Yes, we can change cha_monomorphic_target to nullptr instead of bailing out.  But my understanding is any use of old/redefined methods will cause the compilation to be thrown out when we try to create the nmethod, so we are avoiding wasted work by bailing out early.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/21148#issuecomment-2375409856


More information about the hotspot-compiler-dev mailing list