RFR: 8325467: Support methods with many arguments in C2 [v6]

Dean Long dlong at openjdk.org
Thu Sep 26 23:35:42 UTC 2024


On Thu, 26 Sep 2024 14:06:18 GMT, Daniel Lundén <dlunden at openjdk.org> wrote:

>> If a method has a large number of parameters, we currently bail out from C2 compilation.
>> 
>> ### Changeset
>> 
>> Allowing C2 compilation of methods with a large number of parameters requires fundamental changes to the register mask data structure, used in many places in C2. In particular, register masks currently have a statically determined size and cannot represent arbitrary numbers of stack slots. This is needed if we want to compile methods with arbitrary numbers of parameters. Register mask operations are present in performance-sensitive parts of C2, which further complicates changes.
>> 
>> Changes:
>> - Add functionality to dynamically grow/extend register masks. I experimented with a number of design choices to achieve this. To keep the common case (normal number of method parameters) quick and also to avoid more intrusive changes to the current `RegMask` interface, I decided to leave the "base" statically allocated memory for masks unchanged and only use dynamically allocated memory in the rare cases where it is needed.
>> - Generalize the "chunk"-logic from `PhaseChaitin::Select()` to allow arbitrary-sized chunks, and also move most of the logic into register mask methods to separate concerns and to make the `PhaseChaitin::Select()` code more readable.
>> - Remove all `can_represent` checks and bailouts.
>> - Performance tuning. A particularly important change is the early-exit optimization in `RegMask::overlap`, used in the performance-sensitive method `PhaseChaitin::interfere_with_live`.
>> - Add a new test case `TestManyMethodArguments.java` and extend an old test `TestNestedSynchronize.java`.
>> 
>> ### Testing
>> 
>> - [GitHub Actions](https://github.com/dlunde/jdk/actions/runs/10178060450)
>> - `tier1` to `tier4` (and additional Oracle-internal testing) on Windows x64, Linux x64, Linux aarch64, macOS x64, and macOS aarch64.
>> - Standard performance benchmarking. No observed conclusive overall performance degradation/improvement.
>> - Specific benchmarking of C2 compilation time. The changes increase C2 compilation time by, approximately and on average, 1% for methods that could also be compiled before this changeset (see the figure below). The reason for the degradation is further checks required in performance-sensitive code (in particular `PhaseChaitin::remove_bound_register_from_interfering_live_ranges`). I have tried optimizing in various ways, but changes I found that lead to improvement also lead to less readable code (and are, in my opinion, no...
>
> Daniel Lundén has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains nine additional commits since the last revision:
> 
>  - Remove leftover debug var
>  - Update
>  - Merge tag 'jdk-24+16' into HEAD
>    
>    Added tag jdk-24+16 for changeset c58fbef0
>  - Formatting updates
>  - Update
>  - Update after Roberto's comments and suggestions
>  - Add can_represent asserts
>  - Remove leftover CHUNK_SIZE reference
>  - Support methods with many arguments in C2

src/hotspot/share/opto/optoreg.hpp line 195:

> 193:   static constexpr bool can_fit(OptoReg::Name n) {
> 194:     return n <= std::numeric_limits<Name>::max();
> 195:   }

At first I thought this will always return true, but now I see it is checking OptoReg::Name against OptoRegPair::Name.

src/hotspot/share/opto/optoreg.hpp line 208:

> 206:     assert(can_fit(n + 1), "overflow");
> 207:     assert(can_fit(n), "overflow");
> 208:     _second = n + 1;

I think we could just use checked_cast<>() here and then we don't need can_fit.  What do you think?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20404#discussion_r1777842616
PR Review Comment: https://git.openjdk.org/jdk/pull/20404#discussion_r1777843018


More information about the hotspot-compiler-dev mailing list