RFR: 8346836: C2: Introduce a way to verify the correctness of ConstraintCastNodes at runtime [v5]
Quan Anh Mai
qamai at openjdk.org
Sat Apr 5 06:41:58 UTC 2025
On Fri, 7 Feb 2025 17:02:09 GMT, Vladimir Ivanov <vlivanov at openjdk.org> wrote:
>> Quan Anh Mai has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains seven additional commits since the last revision:
>>
>> - Merge branch 'master' into verifycast
>> - better comments
>> - move test to a new file, add block_comment
>> - add tests
>> - make VerifyConstraintCast uint, better debug info
>> - Merge branch 'master' into verifycast
>> - Introduce VerifyConstraintCasts
>
> src/hotspot/cpu/x86/c2_MacroAssembler_x86.cpp line 840:
>
>> 838:
>> 839: #ifdef ASSERT
>> 840: void C2_MacroAssembler::checked_cast_int(const TypeInt* type, Register dst) {
>
> Naming is a bit confusing here. It is a register which holds the value being range checked, not a register where new value is put.
I have renamed it to `val`
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/22880#discussion_r2029784445
More information about the hotspot-compiler-dev
mailing list