RFR: 8355472: Clean up x86 nativeInst after 32-bit x86 removal [v2]
Manuel Hässig
duke at openjdk.org
Mon Apr 28 12:15:00 UTC 2025
On Mon, 28 Apr 2025 08:38:48 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:
>> Manuel Hässig has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Apply readability suggestion
>>
>> Co-authored-by: Aleksey Shipilëv <shipilev at amazon.de>
>
> src/hotspot/cpu/x86/nativeInst_x86.cpp line 305:
>
>> 303: // make sure code pattern is actually a mov [reg+offset], reg instruction
>> 304: u_char test_byte = *(u_char*)instruction_address();
>> 305: if (!((test_byte == lea_instruction_code) || (test_byte == mov64_instruction_code))) {
>
> Suggestion:
>
> if ((test_byte != lea_instruction_code) && (test_byte != mov64_instruction_code)) {
That looks much nicer. Thanks for the suggestion!
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/24911#discussion_r2063528814
More information about the hotspot-compiler-dev
mailing list