RFR: 8351568: Improve source code documentation for PhaseCFG::insert_anti_dependences
Daniel Lundén
dlunden at openjdk.org
Wed Apr 30 09:51:45 UTC 2025
On Tue, 29 Apr 2025 04:56:59 GMT, Galder Zamarreño <galder at openjdk.org> wrote:
>> The current documentation for `PhaseCFG::insert_anti_dependences` is difficult to follow and sometimes even misleading. We should ensure the method is appropriately documented.
>>
>> ### Changeset
>>
>> - Rename `PhaseCFG::insert_anti_dependences` to `PhaseCFG::raise_above_anti_dependences`. The purpose of `PhaseCFG::raise_above_anti_dependences` is twofold: raise the load's LCA so that the load is scheduled before anti-dependent stores, and if necessary add anti-dependence edges between the load and certain anti-dependent stores (to ensure we later "raise" the load before anti-dependent stores in LCM). The name `PhaseCFG::insert_anti_dependences` suggests that we only add anti-dependence edges. The name `PhaseCFG::raise_above_anti_dependences`, therefore, seems more appropriate.
>> - Significantly add to and revise the source code documentation of `PhaseCFG::raise_above_anti_dependences`.
>> - Add, move, and revise `assert`s in `PhaseCFG::raise_above_anti_dependences`, including improved `assert` messages in a few places.
>> - In the main worklist loop of `PhaseCFG::raise_above_anti_dependences`:
>> - Clean up how we identify the search root (avoid mutation).
>> - Add a missing early exit for `Phi` nodes when `LCA == early`.
>>
>> ### Testing
>>
>> - [GitHub Actions](https://github.com/dlunde/jdk/actions/runs/14706896111)
>> - `tier1` to `tier4` (and additional Oracle-internal testing) on Windows x64, Linux x64, Linux aarch64, macOS x64, and macOS aarch64.
>
> src/hotspot/share/opto/gcm.cpp line 912:
>
>> 910: // they CAN write to Java memory.
>> 911: if (muse->ideal_Opcode() == Op_CallStaticJava) {
>> 912: assert(muse->is_MachSafePoint(), "");
>
> I know there was not assert message before, but can we use the opportunity to add a meaningful message for this assert? There's another empty message assert a few lines before.
Thanks for the comments @galderz! I do not know the specifics of this particular part of `insert_anti_dependences`. I could add generic assert messages, based on the checks, for the purpose of avoiding empty messages. But I'm not sure those are then meaningful messages.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/24926#discussion_r2068332601
More information about the hotspot-compiler-dev
mailing list