Merging BSDPort into HotSpot mainline

Tom Rodriguez tom.rodriguez at oracle.com
Fri Sep 16 12:32:59 PDT 2011


On Sep 16, 2011, at 11:49 AM, John Rose wrote:

> On Sep 16, 2011, at 10:35 AM, Tom Rodriguez wrote:
> 
>>> The PRIxnn macro simplifications are good.  Perhaps the final form of them in globalDefinitions could be reorganized a little, also?  The parallel 32-bit and 64-bit definitions occur in different order and with different spacing.  This irregularity makes them harder to read.
>> 
>> You mean the grouping?  How about this?  I also simplified the pointer comment.
> 
> Yes, that's easier to process.
> 
> One more nit:  In the last stanza "uint" comes before "int", where elsewhere the signed versions come first.  I suggest swapping lines 1 and 2 here:
> 
>> #define UINTX_FORMAT          "%" PRIuPTR
>> #define INTX_FORMAT           "%" PRIdPTR
>> #define UINTX_FORMAT_W(width) "%" #width PRIuPTR

Fixed.

tom

>> 
>>> I looked at the helpful differences you posted between Linux and BSD.  I noticed that there is a definition (bsd_{x86,zero}) of SurvivorRatio introduced which apparently reproduces the definition in the shared globals.hpp, and is not in the linux side.  Do we need it?
>> 
>> It seems useless since SurvivorRatio isn't product_pd.  I'll remove it.
>> 
>> Thanks!
> 
> You're welcome.
> 
> -- John



More information about the hotspot-dev mailing list