RFR(M) : 7104565 : trim jprt build targets

Coleen Phillimore coleen.phillimore at oracle.com
Wed Apr 10 09:01:23 PDT 2013


On 4/10/2013 11:34 AM, David Chase wrote:
> David, Vladimir (and anyone else)
>
>>> Looking at stackMapFrame.hpp the changeset that added the "ifdef DEBUG" was
>>>
>>> http://hg.openjdk.java.net/hsx/hotspot-rt/hotspot/rev/4ee06e614636
>>>
>>> and it seems to me that perhaps it should have been
>>> "ifndef PRODUCT" based on the fact that it appears to be a refactoring
>>> of NOT_PRODUCT code. (The only difference being whether or not it is
>>> included in the optimized build.)
>> I think, the intention of changes was to not include it into optimized build but may be there was confusion about DEBUG vs ASSERT.
> Is this a proposed change for this fix in this file (replace ifdef ASSERT with ifndef PRODUCT)
> or is this a change for some future fix, or is this a road-not-taken?

Yes, I think it was confusion which to use.  It should be ASSERT.
Coleen

>
> I'm happy either way, the editor is open, I just want to get all moles properly whacked.
> (other moles -- jvmgminimal1 and llvmHeaders.hpp -- are whacked)
>
> David
>



More information about the hotspot-dev mailing list