[9] RFR(L): 8037816 : Fix for 8036122 breaks build with Xcode5/clang
Vladimir Kozlov
vladimir.kozlov at oracle.com
Wed Apr 30 17:39:36 UTC 2014
On 4/30/14 4:59 AM, David Chase wrote:
>
> On 2014-04-30, at 5:09 AM, David Holmes <david.holmes at oracle.com> wrote:
>>> How do you like it otherwise? I'm itching to get reviews and get this thing out of my hair.
>>
>> I appreciate what you are doing but I dislike the details - in particular print_raw and, even worse, cr().
>>
>> One thing we do need from this is some clear documentation somewhere on what format specific macros to use for which types.
>
> You do understand that those are both existing public methods, and I did not add or innovate, right?
> It's also completely nonintuitive to me that you would dislike cr more than print_raw.
>
> Rather than document, we could make them not be public, if we really meant for them not to be called.
> I prefer Vladimir's proposal to rename print_raw into puts.
>
> One thing that is a little puzzling to me is why we have both INTX and INT64.
INTX is 32 bit in 32 bit VM:
// intx and uintx are the 'extended' int and 'extended' unsigned int types;
// they are 32bit wide on a 32-bit platform, and 64bit wide on a 64bit platform.
typedef intptr_t intx;
typedef uintptr_t uintx;
Vladimir
> I see no purpose whatsoever for INTX; it appears to be a 64-bit integer type,
> but we have a well-defined 64-bit integer type (INT64) and a not-well-defined
> 64-bit integer type (JLONG) that we own because it is Ours. We also have a
> pointer-sized integer type (INTPTR) and if this is actually a distinction,
> an "I intend to print this integer as a pointer type" (PTR).
>
> David
>
More information about the hotspot-dev
mailing list