RFR: 8068396: Rename assert() to vmassert()
Coleen Phillimore
coleen.phillimore at oracle.com
Fri Jan 9 00:43:43 UTC 2015
My prior email asked if you could test this change by changing an assert
to vmassert. The assert in debug.cpp test_error_handler to vmassert
would be a good one to test this change.
thanks,
Coleen
On 1/8/15, 6:57 PM, Kim Barrett wrote:
> On Jan 7, 2015, at 12:07 PM, Kim Barrett <kim.barrett at oracle.com> wrote:
>> Erik Helin pointed out to me that the change to the assertion text
>> from "assert(...)" to "vmassert(...)" might break some existing JBS
>> RULE comments for matching known failures.
>>
>> I'll look at how bad this really is, but it seems likely that the
>> thing to do is to revert the message text back to using "assert"
>> rather than "vmassert".
> I've reverted the message string back to saying "assert(" rather than
> "vmassert(". I'm working on getting an aurora test with the
> "vmassert(" string to see how bad that change might be, but I'm not
> sure I've done that properly yet. Regardless, the argument for
> reverting that string change seems pretty compelling.
>
> I looked at what will happen with [vm]assert_status, which was
> simplified to just expand into a vmassert rather than duplicating the
> implementation of that macro. The assert_status predicate expression
> gets included in the message string in the same way under the new as
> the old, so with vmassert message string reversion there won't be any
> change here either.
>
> I looked at assert_if_no_error similarly; it used to just expand into
> assert and now expands into vmassert, so again no change in the
> message.
>
> For testing, I did builds with and without these changes, with
> temporary code inserted to always fail an assertion, and verified that
> the relevant message texts were identical.
>
> CR: https://bugs.openjdk.java.net/browse/JDK-8068396
> New webrev: http://cr.openjdk.java.net/~kbarrett/8068396/webrev.02
> Incremental webrev: http://cr.openjdk.java.net/~kbarrett/8068396/webrev.02.incr
>
> The new webrev contains copyright updates, since its a new year. I
> left the copyright updates out of the incremental webrev.
>
>
More information about the hotspot-dev
mailing list