Unasafe.putOdered -> Unsafe.releasePut
Paul Sandoz
paul.sandoz at oracle.com
Mon Mar 2 10:04:44 UTC 2015
Hi,
In light of the changes to clean up OrderAccess implementations [1] what to people think about:
1) deprecating the putOrdered* methods and renaming to release*Put?
2) adding a get*Acquire*. Initial implementations could defer to the relaxed operation followed by a load fence, but we should re-implement natively as a bound variant since the initial implementation is likely to be more conservative. I want to add such methods for VarHandle support.
3) perhaps deprecating/renaming the Unsafe fences to align with the fence/release/acquire naming.
?
At one level most of this is kind of cosmetic but given this area is very confusing using consistent naming seems worthwhile.
Paul.
[1] http://cr.openjdk.java.net/~dholmes/7143664/webrev-v5/src/share/vm/runtime/orderAccess.hpp.sdiff.html
More information about the hotspot-dev
mailing list