RFR 8074717: Merge interp_masm files for x86 _32 and _64

serguei.spitsyn at oracle.com serguei.spitsyn at oracle.com
Tue Mar 10 01:52:35 UTC 2015


Hi Coleen,

It looks good.

Just one comment:

  src/cpu/x86/vm/interp_masm_x86_32.cpp
  src/cpu/x86/vm/interp_masm_x86_64.cpp

   1656     get_thread(rthread);
   . . .
   1669     get_thread(rthread);

Should it be?:
   1656NOT_LP64(get_thread(rthread));
   . . .
   1669NOT_LP64(get_thread(rthread));


To be safe, it'd be nice to run the nsk.quick-jdi.testlist in both 32- 
and 64-bit mode,
which include more PopFrame and ForceEarlyReturn tests.


Thanks,
Serguei



On 3/9/15 1:36 PM, Coleen Phillimore wrote:
> Summary: Merge duplicate code and use #ifdef for non-mergeable sections.
>
> Inspired by Max's change and because I was working on this with him, 
> I've merged interp_masm_x86_32 and _64.cpp/hpp files.
>
> There are two webrevs generated.  The first webrev is generated to see 
> the diffs.   Mostly the _64 contents are chosen because the formatting 
> was better.  The second is moving the code into the already existant 
> interp_masm_x86.cpp/hpp files.
>
> Ran all jck tests on this and JPRT, also ran NSK vm.quick.testlist 
> which includes jvmti tests.
>
> bug link https://bugs.openjdk.java.net/browse/JDK-8074717
> open webrev at http://cr.openjdk.java.net/~coleenp/8074717
> open webrev at http://cr.openjdk.java.net/~coleenp/8074717_2/
>
> Thanks,
> Coleen



More information about the hotspot-dev mailing list