RFR 8074717: Merge interp_masm files for x86 _32 and _64
harold seigel
harold.seigel at oracle.com
Fri Mar 13 17:35:24 UTC 2015
Hi Coleen,
The changes look good but I have a few questions.
1. Why were rsi and rdi sometimes replaced with r13 and r14, and other
times with esi and edi, or bcp_register?
2. Do you plan to delete the "// XXX l ?" comments?
3. How did you choose when to use long vs. ptr instructions?
4. At line 756 in interp_masm_x86_64.cpp, Why do the move here? Why not
just unlock_object(rmon) ?
5. At lines 814 and 1601 in interp_masm_x86_64.cpp, why /* */ instead of
// for: #endif /* !CC_INTERP */
Thanks, Harold
On 3/9/2015 4:36 PM, Coleen Phillimore wrote:
> Summary: Merge duplicate code and use #ifdef for non-mergeable sections.
>
> Inspired by Max's change and because I was working on this with him,
> I've merged interp_masm_x86_32 and _64.cpp/hpp files.
>
> There are two webrevs generated. The first webrev is generated to see
> the diffs. Mostly the _64 contents are chosen because the formatting
> was better. The second is moving the code into the already existant
> interp_masm_x86.cpp/hpp files.
>
> Ran all jck tests on this and JPRT, also ran NSK vm.quick.testlist
> which includes jvmti tests.
>
> bug link https://bugs.openjdk.java.net/browse/JDK-8074717
> open webrev at http://cr.openjdk.java.net/~coleenp/8074717
> open webrev at http://cr.openjdk.java.net/~coleenp/8074717_2/
>
> Thanks,
> Coleen
More information about the hotspot-dev
mailing list