RFR: 8077571: ObjPtrQueue is poorly named
Christian Thalinger
christian.thalinger at oracle.com
Mon Nov 9 17:36:31 UTC 2015
> On Nov 7, 2015, at 10:58 AM, Kim Barrett <kim.barrett at oracle.com> wrote:
>
> On Nov 6, 2015, at 5:21 PM, Christian Thalinger <christian.thalinger at oracle.com> wrote:
>>
>>
>>> On Nov 6, 2015, at 12:09 PM, Kim Barrett <kim.barrett at oracle.com> wrote:
>>>
>>> [Sending to hotspot-dev because this touches runtime and compiler
>>> files too. I'm particularly looking for a compiler person for the
>>> change to HotSpotVMConfig.java.]
>>
>> Yes, that change looks good.
>
> Thanks! I wasn’t getting anywhere trying to figure out what might be impacted by that change.
It’s really not that complicated. A HotSpotVMField annotation reads a property specified by “get” for a C++ field with the name “name” with the type “type”. In this case:
+ @HotSpotVMField(name = "JavaThread::_satb_mark_queue", type = "SATBMarkQueue", get = HotSpotVMField.Type.OFFSET) @Stable public int javaThreadSatbMarkQueueOffset;
it is reading the offset of the field JavaThread::_satb_mark_queue. The type is only used for verification.
>
>>> Please review this rename of ObjPtrQueue to SATBMarkQueue. This
>>> cleanup is being done in preparation for some further changes that
>>> will make the name more widely used.
>>>
>>> Probably the satbQueue.[ch]pp files should be renamed to
>>> satbMarkQueue.[ch]pp. I've not made such a change because my
>>> understanding is that mercurial mq doesn't really understand file
>>> renames.
>>>
>>> CR:
>>> https://bugs.openjdk.java.net/browse/JDK-8077571
>>>
>>> Webrev:
>>> http://cr.openjdk.java.net/~kbarrett/8077571/webrev.00/
>>>
>>> Testing:
>>> JPRT
>
>
More information about the hotspot-dev
mailing list