RFR: 8155043: BitMap set operations assume clear bits beyond unaligned end
Jon Masamitsu
jon.masamitsu at oracle.com
Fri Aug 12 21:06:08 UTC 2016
Kim,
This patch is good to go as is but I just have some questions.
Did you give any consideration to just having set_union_with_result()
and using it where set_union() is used (ignoring the return value)?
I note in the test parameters with double underscore in the names.
162 TEST(BitMap, is_full_or_empty__aligned)
I can see how it aids readability but it seems new. Is it new
and did you decide it was a convention worth using?
As I said, good to go as is.
Jon
On 8/11/2016 4:48 PM, Kim Barrett wrote:
>> On Aug 9, 2016, at 4:31 AM, Stefan Karlsson <stefan.karlsson at oracle.com> wrote:
>>
>> On 2016-08-08 20:56, Kim Barrett wrote:
>>>> On Aug 5, 2016, at 9:27 AM, Stefan Karlsson <stefan.karlsson at oracle.com> wrote:
>>>>
>>>> Hi Kim,
>>>>
>>>> This looks mostly good to me. I have a few comments inlined:
>>> Thanks for looking at this.
>>>
>>> New webrevs:
>>> full: http://cr.openjdk.java.net/~kbarrett/8155043/webrev.01/
>>> incr: http://cr.openjdk.java.net/~kbarrett/8155043/webrev.01.inc/
>> Reviewed.
> Thanks.
>
> Any other reviewers?
>
More information about the hotspot-dev
mailing list