RFR: JDK-8157453 - Convert DependencyContext_test to GTest

David Holmes david.holmes at oracle.com
Tue Aug 30 04:26:26 UTC 2016


Hi Kirill,

On 30/08/2016 5:32 AM, Kirill Zhaldybin wrote:
> Jesper,
>
> As far as I understand test_dependencyContext could be run in both
> product and debug.
> But in the class DependencyContext
>
>  148 #ifndef PRODUCT
>  149   void print_dependent_nmethods(bool verbose);
>  150   bool is_dependent_nmethod(nmethod* nm);
>  151   bool find_stale_entries();
>  152 #endif //PRODUCT
>
> so is_dependent_nmethod and find_stale_entries are compiled only in
> non-product configs but they are used in test_dependencyContext

I presume this is why these calls are wrapped in the ASSERT_TRUE and 
ASSERT_FALSE macros - I expect them to be no-ops in a product build. But 
I can't find the definitions of these ASSERT_xxx macros ??

David
-----






> Have you tried to build VM and run this test in product config?
>
> http://cr.openjdk.java.net/~jwilhelm/8157453/webrev.00/test/native/code/test_dependencyContext.cpp.html
>
>
>   86 TEST(code, dependency_context) {
>
> According to "almost existing naming convention" the test should be
> named (<Tested Class>, <Test Case>).
>
> Thank you.
>
> Regards, Kirill
>
> On 25.08.2016 20:53, Jesper Wilhelmsson wrote:
>> Hi,
>>
>> Please review this test conversion of the DependencyContext tests to
>> GTest.
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8157453
>> Webrev: http://cr.openjdk.java.net/~jwilhelm/8157453/webrev.00/
>>
>> Thanks,
>> /Jesper
>


More information about the hotspot-dev mailing list