RFR 8147039 : Incorrect locals and operands in compiled frames
Mandy Chung
mandy.chung at oracle.com
Tue May 3 20:45:01 UTC 2016
> On May 3, 2016, at 12:00 PM, Brent Christian <brent.christian at oracle.com> wrote:
>
> Hi,
>
> Please review this change which fixes buggy behavior (including SEGV) in the experimental LiveStackFrame feature of StackWalker.
>
> Bug:
> https://bugs.openjdk.java.net/browse/JDK-8147039
> Webrev:
> http://cr.openjdk.java.net/~bchristi/8147039/webrev.02/
>
> As suggested in the bug report, stack walking is reimplemented using javaVFrame/vframe::java_sender. The native StackWalkerAnchor class is updated (and renamed) with a similar interface and function to vframeStream. I've also removed the now-unneeded vframeStreamCommon::java_frame() function, added by 8140450.
This patch looks good. I’m happy that the fix turns out to be very simple and clean.
One minor nit: in stackwalk.cpp, the local variable “anchor” used in a couple places should also be renamed. You can fix that up before you push (no need for a new webrev)
thanks
Mandy
More information about the hotspot-dev
mailing list