RFR: 8178499: Remove _ptr_ and _size_ infixes from align functions
Thomas Schatzl
thomas.schatzl at oracle.com
Tue Jul 4 11:56:20 UTC 2017
Hi Stefan,
On Fri, 2017-06-30 at 11:40 +0200, Stefan Karlsson wrote:
> Hi all,
>
> Please review this patch to remove the _ptr_ and _size_ infixes from
> align functions.
>
> http://cr.openjdk.java.net/~stefank/8178499/webrev.00
> http://bugs.openjdk.java.net/browse/JDK-8178499
>
> Rename functions (and corresponding macros) from:
> align_ptr_up
> align_size_up
> align_ptr_down
> align_size_down
> is_ptr_aligned
> is_size_aligned
>
> to:
> align_up
> align_down
> is_aligned
>
> The patch builds upon the changes in:
> http://mail.openjdk.java.net/pipermail/hotspot-dev/2017-June/027328
> .html
>
looks good. I am not sure if I am happy about the renamings of the
non-global align* methods, as they at least sometimes seemed to have
been part of the item you wanted to align. E.g.
ReservedSpace::page_align_size_* to ReservedSpace::page_align_*.
There is at least one name clash because of that is resolved using the
"::" specifiers (in space.cpp:~670). Or maybe this can be resolved by
different naming in ReservedSpace.
Unless somebody else also objects, consider this as not a blocking
issue.
Thanks,
Thomas
More information about the hotspot-dev
mailing list