RFR[12]: 8204834: Fix confusing "allocate" naming in OopStorage

Kim Barrett kim.barrett at oracle.com
Sun Jul 8 16:00:15 UTC 2018


Please review this nomenclature change in the implementation of
OopStorage.  This is a followup to JDK-8204097; in the review of that
change Coleen noted that some names were confusing, especially
"allocate_list()", which is an accessor and doesn't allocate anything!

This is a mostly mechanical change:

AllocateList => AllocationList  
_allocate_list => _allocation_list 
allocate_list() => allocation_list()  

AllocateEntry => AllocationListEntry
_allocate_entry => _allocation_list_entry
allocate_entry() => allocation_list_entry()

_allocate_mutex => _allocation_mutex

There are a few non-mechanical changes in comments, to make the
comments consistently use the same names as the code.  For example,
some underscores were added when referring to members in comments.
Also fixed a few related typos.

CR:
https://bugs.openjdk.java.net/browse/JDK-8204834

Webrev:
http://cr.openjdk.java.net/~kbarrett/8204834/open.00/

Testing:
mach5 tier1



More information about the hotspot-dev mailing list