[12] RFR 8206895: aarch64: rework error-prone cmp instuction

Boris Ulasevich boris.ulasevich at bell-sw.com
Mon Jul 9 15:33:18 UTC 2018


sorry. updated review link:
http://cr.openjdk.java.net/~bulasevich/8206895/webrev.01

On 09.07.2018 18:32, Boris Ulasevich wrote:
> I am not sure how to mark instruction deprecated. Why don't just remove 
> it and update all the usage points? Here is the updated review:
> 
> http://cr.openjdk.java.net/~bulasevich/8206895/webrev.01
> 
> Boris
> 
> On 09.07.2018 17:50, Andrew Haley wrote:
>> On 07/09/2018 03:31 PM, Boris Ulasevich wrote:
>>> http://cr.openjdk.java.net/~bulasevich/8206895/webrev.00
>>> https://bugs.openjdk.java.net/browse/JDK-8206895
>>>
>>> Byte form of cmp instruction was added. For bigger constants we are
>>> supposed to state _imm12 postfix implicitly or use cmp(reg,reg,imm) 
>>> macro.
>>
>> I don't think that making cmp an alias for subs helps anyone:
>>
>> +  inline void cmp(Register Rd, Register Rn, unsigned imm32)  { 
>> subs(Rd, Rn, imm32); }
>>
>> I think the best suggestion was to make the 8-bit cmp the only form
>> allowed, mark the larger cmp as deprecated, and force the user to use
>> subs.  That would be easier to read than cmp_imm12().
>>


More information about the hotspot-dev mailing list