RFR: 8204097: Simplify OopStorage::AllocateList block entry access

Kim Barrett kim.barrett at oracle.com
Tue Jun 12 00:54:37 UTC 2018


> On Jun 1, 2018, at 9:13 AM, coleen.phillimore at oracle.com wrote:
> 
> 
> Hi Kim,   This change looks fine, except these names caused me a lot of confusion.
> 
> http://cr.openjdk.java.net/~kbarrett/8204097/open.00/src/hotspot/share/gc/shared/oopStorage.cpp.udiff.html
> 
> + block.allocate_entry()._next = old;
> + old->allocate_entry()._prev = █
> 
> This allocate_entry() call doesn't actually allocate anything but get the allocation list entry.   Can these things be renamed in a subsequent RFE?

Thanks for reviewing.

https://bugs.openjdk.java.net/browse/JDK-8204834

> 
> thanks,
> Coleen
> 
> On 5/30/18 4:19 PM, Kim Barrett wrote:
>> Please review this simplification of OopStorage::AllocateList,
>> removing the no longer used support for blocks being in multiple lists
>> simultaneously. There is now only one list of blocks, the
>> _allocate_list.
>> 
>> CR:
>> https://bugs.openjdk.java.net/browse/JDK-8204097
>> 
>> Webrev:
>> http://cr.openjdk.java.net/~kbarrett/8204097/open.00/
>> 
>> Testing:
>> Mach5 tier{1,2,3}




More information about the hotspot-dev mailing list