RFR: 8220658: Improve the readability of container information in the error log

Jie Fu fujie at loongson.cn
Wed Mar 20 06:07:55 UTC 2019


Thanks David.

Actually, I prefer "not supported" to "failed".
I'm also OK to change it back if someone has different ideas.

Best regards,
Jie

On 2019/3/20 下午1:49, David Holmes wrote:
> Hi Jie,
>
> On 19/03/2019 5:49 pm, Jie Fu wrote:
>> Hi David,
>>
>> Thank you so much for your review and suggestions.
>>
>> Please review the second version: 
>> http://cr.openjdk.java.net/~jiefu/8220658/webrev.01/
>
> This seems okay to me.
>
> I have to admit that when looking at the original diff, I did not 
> notice that other sections already reported "failed". If I had noticed 
> I may not have suggested using "not supported" instead. Lets see what 
> others think. I've cc'd Bob to see if he can also review this.
>
> Thanks,
> David
> -----
>
>> Thanks a lot.
>>
>> Best regards,
>> Jie
>>
>>
>> On 2019/3/19 上午5:43, David Holmes wrote:
>>> Hi Jie,
>>>
>>> On 14/03/2019 8:00 pm, Jie Fu wrote:
>>>> Hi all,
>>>>
>>>> Bug:    https://bugs.openjdk.java.net/browse/JDK-8220658
>>>> Webrev: http://cr.openjdk.java.net/~jiefu/8220658/webrev.00/
>>>
>>> This seems a reasonable improvement, but I have a couple of 
>>> suggestions. To avoid so much duplication you can change this 
>>> structure:
>>>
>>>    if (i > 0) {
>>>      st->print("cpu_quota: %d\n", i);
>>>    } else {
>>>      st->print("cpu_quota: %s\n", i == OSCONTAINER_ERROR ? "failed" 
>>> : "no quota");
>>>    }
>>>
>>> to this:
>>>
>>>    st->print("cpu_quota: ");
>>>    if (i > 0) {
>>>       st->print("%d\n", i);
>>>    } else {
>>>      st->print("%s\n", i == OSCONTAINER_ERROR ? "failed" : "no quota");
>>>    }
>>>
>>> Also I suggest replacing "failed" with "not supported".
>>>
>>> Finally one minor typo: s/"no share"/"no shares"/
>>>
>>> Thanks,
>>> David
>>> -----
>>>
>>>> In the VM's error log, the container information was dumpped as:
>>>> ---------------------------------
>>>> container (cgroup) information:
>>>> container_type: cgroupv1
>>>> cpu_cpuset_cpus: 0-11
>>>> cpu_memory_nodes: 0
>>>> active_processor_count: 12
>>>> cpu_quota: -1
>>>> cpu_period: 100000
>>>> cpu_shares: -1
>>>> memory_limit_in_bytes: -1
>>>> memory_and_swap_limit_in_bytes: -2
>>>> memory_soft_limit_in_bytes: -1
>>>> memory_usage_in_bytes: 11690164224
>>>> memory_max_usage_in_bytes: 1806413824
>>>> ---------------------------------
>>>>
>>>> Items such as "memory_limit_in_bytes" and 
>>>> "memory_and_swap_limit_in_bytes" are difficult to understand.
>>>>
>>>> It might be more human-readable if we could dump it like this:
>>>> ---------------------------------
>>>> container (cgroup) information:
>>>> container_type: cgroupv1
>>>> cpu_cpuset_cpus: 0-11
>>>> cpu_memory_nodes: 0
>>>> active_processor_count: 12
>>>> cpu_quota: no quota
>>>> cpu_period: 100000
>>>> cpu_shares: no share
>>>> memory_limit_in_bytes: unlimited
>>>> memory_and_swap_limit_in_bytes: failed
>>>> memory_soft_limit_in_bytes: unlimited
>>>> memory_usage_in_bytes: 11690164224
>>>> memory_max_usage_in_bytes: 1806413824
>>>> ---------------------------------
>>>>
>>>> I made this patch to improve the readability of container 
>>>> information in the error log.
>>>> The change has been tested with hotspot:tier1 on Linux/x86-64.
>>>>
>>>> Could you please review it?
>>>> Thanks a lot.
>>>>
>>>> Best regards,
>>>> Jie
>>>>
>>>>
>>



More information about the hotspot-dev mailing list