RFR: 8234796: Refactor Handshake::execute to take a HandshakeOperation

Robbin Ehn robbin.ehn at oracle.com
Tue Nov 26 13:07:41 UTC 2019


Hi all, please review.

Issue:
https://bugs.openjdk.java.net/browse/JDK-8234796
Code:
http://cr.openjdk.java.net/~rehn/8234796/full/webrev/

The handshake code needs more information about the handshake operation.
We change type from ThreadClosure to HandshakeOperation in Handshake::execute.
This enables us to add more details to the HandshakeOperation as needed going 
forward.

Tested t1 and t1-3 together with the logging improvements in 8234742.

It was requested that "HandshakeOperation()" would take the name instead having 
"virtual const char* name();". Which is in this patch.

Thanks, Robbin


More information about the hotspot-dev mailing list