RFR: JDK-8257588: Make os::_page_sizes a bitmask [v3]
Marcus G K Williams
github.com+168222+mgkwill at openjdk.java.net
Thu Dec 3 22:59:06 UTC 2020
On Thu, 3 Dec 2020 21:23:46 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:
>> Thomas Stuefe has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Feedback Thomas
>
> src/hotspot/share/runtime/os.hpp line 110:
>
>> 108: PagesizeSet() : _v(0) {}
>> 109: void add(size_t pagesize);
>> 110: bool is_set(size_t pagesize) const;
>
> Could this be private. It's an implementation detail that you use a bit set and have "set" bits. If not, maybe consider a more high-level name. is_added, is_registered, contains?
I'd prefer if this stays public, I've already found it useful, but I agree that the name could be more informative. Perhaps contains(size_t pagesize)?
-------------
PR: https://git.openjdk.java.net/jdk/pull/1522
More information about the hotspot-dev
mailing list