RFR: JDK-8255711: Fix and unify hotspot signal handlers [v3]

Thomas Stuefe stuefe at openjdk.java.net
Fri Nov 6 12:56:19 UTC 2020


On Thu, 5 Nov 2020 20:30:01 GMT, Gerard Ziemski <gziemski at openjdk.org> wrote:

>> Thanks for the review, Gerard! I'll wait for Davids feedback, since he may want more changes done.
>
> Thank you Thomas for the work, I really like the cleanup here!

I added some more minor cleanups:

- added missing include (atomic.hpp)

- CDT complained about check_pending_signals() not returning a value upon exit; we never exit, so thats fine, but I added a return and a ShouldNotReachHere just for clarity.

Review-triggered fixes:

- @gerard-ziemski: removed the "set_installed" parameter from set_signal_handler. That parameter was used to reset the signal 
back to the default handler. But that had not been used. And it had been incorrect too, since the correct way of doing this would have been to reset to any chained handler if one was present when the hotspot signal handler was installed.

- @gerard-ziemski: increased the buffer size for the signal name in little robots text bubble to 64.

- @gerard-ziemski: moved definition of jt closer to where its needed.

- @dholmes-ora: as requested, I merged javaSignalHandler_inner() and JVM_handle_xxx_signal(). I am not super happy about this - one thing I immediately noticed is that now I cannot assert for "+AllowUserSignalHandlers" to make sure this function is only called then. But I can live with it.

-------------

PR: https://git.openjdk.java.net/jdk/pull/1034


More information about the hotspot-dev mailing list