RFR: 8253064: monitor list simplifications and getting rid of TSM [v3]
David Holmes
dholmes at openjdk.java.net
Tue Nov 10 01:05:59 UTC 2020
On Mon, 9 Nov 2020 20:42:19 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:
>> Changing it to a do/while loop makes sense. The while condition is always true the first iteration, so doing a while or do/while loop is equivalent. If you find the do/while loop easier to read, then that sounds good to me.
>
> Okay. I've changed it to a do-while loop.
The loop that was being discussed here is the one on line 93 of the original changeset:
`while (next != NULL && next->is_being_async_deflated()) {`
I made no comment on the outer while loop.
-------------
PR: https://git.openjdk.java.net/jdk/pull/642
More information about the hotspot-dev
mailing list