RFR: 8256365: Clean up vtable initialization code [v2]

Coleen Phillimore coleenp at openjdk.java.net
Wed Nov 18 02:57:06 UTC 2020


On Wed, 18 Nov 2020 02:30:55 GMT, David Holmes <dholmes at openjdk.org> wrote:

>> Coleen Phillimore has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Revert RedefineClasses fix and remove InstanceKlass argument from update_inherited_vtable so which klass is clear.
>
> Hi Coleen,
> Why do you consider `is_override` to be in the wrong place? (It is badly named - should be `can_override` or `is_overridable`). I think of overriding as being a feature/property of a class not a vtable.
> Anyway all the cleanups appear to be fine.
> Thanks,
> David

The function is_override should be colocated with the functions that call it that implement overriding rules for selection for vtable initialization, which are very complicated.  can_be_overridden might be a better name for it.  I'll change it. That's a minor change.

// Returns true iff super_method can be overridden by a method in targetclassname
It'll match the comment also.

Thanks for the code review!

-------------

PR: https://git.openjdk.java.net/jdk/pull/1236


More information about the hotspot-dev mailing list