RFR: 8236926: Concurrently uncommit memory in G1 [v7]

Thomas Schatzl tschatzl at openjdk.java.net
Thu Nov 19 08:33:10 UTC 2020


On Wed, 18 Nov 2020 20:34:42 GMT, Stefan Johansson <sjohanss at openjdk.org> wrote:

>> src/hotspot/share/gc/g1/heapRegionManager.cpp line 181:
>> 
>>> 179:     G1CollectedHeap::heap()->hr_printer()->commit(hr);
>>> 180:   }
>>> 181:   activate_regions(start, num_regions);
>> 
>> In this place there will be two messages from the HRPrinter for every region:
>> 1) a COMMIT message and
>> 2) an ACTIVATE message
>> 
>> This is a bit confusing as in my understanding (that's why I asked for a region state diagram in the `G1CommittedRegionMap` which may as well be put in `HeapRegionManager`) the (typical) flow of states are Uncommitted->Committed/Active->Committed/Inactive->Uncommitted.
>> As mentioned, I'm not sure if it is a good idea to send two separate messages here; better rename the "Active" message to "Commit-Active" (and "Inactive" to "Commit-Inactive") instead imho, even if it's quite long (and drop `HRPrinter::commit()` completely)
>
> It's true that it will generate two messages when committing a previously uncommitted region, but I still think it is valuable to separate them since we can also have the state change `Active->Inactive->Active`. In this case the transition from Inactive to Active will not include a commit, but rather making inactive regions active again. Just seeing a "Commit-Active" message in this case would not be as clear as seeing "Active" that is not immediately preceded by "Commit".

Okay, I looked at the `G1HRPrinter` again, and indeed it prints the action, not the region state, so this is a fair point.

-------------

PR: https://git.openjdk.java.net/jdk/pull/1141


More information about the hotspot-dev mailing list