RFR: 8259242: vmTestbase/vm/mlvm/mixed/stress/java/findDeadlock/TestDescription.java timed out

David Holmes david.holmes at oracle.com
Thu Apr 8 09:48:38 UTC 2021


On 7/04/2021 10:30 pm, Coleen Phillimore wrote:
> On Wed, 7 Apr 2021 11:55:56 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
> 
>>> src/hotspot/share/classfile/protectionDomainCache.hpp line 115:
>>>
>>>> 113:
>>>> 114:   ProtectionDomainEntry* next() { return Atomic::load(&_next); }
>>>> 115:   void set_next(ProtectionDomainEntry* entry) { Atomic::store(&_next, entry); }
>>>
>>> Again these may need to be load_acquire/release_store for correct lock-free traversal. With suitable name changes for the methods.
>>
>> Thanks, I'll add acquire/release and change the names to match the implementation details.
> 
> Did we collectively agree on the naming convention that set_next has to be release_set_next because the implementation uses release_store, or is this just your preference?  I find this noisy in the context where these functions are being called.

Yes that is the convention that was established and in place for a 
number of fields.

Thanks,
David

> -------------
> 
> PR: https://git.openjdk.java.net/jdk/pull/3362
> 


More information about the hotspot-dev mailing list