RFR: 8269004 Implement ResizableResourceHashtable [v2]

Coleen Phillimore coleenp at openjdk.java.net
Tue Jun 29 21:04:40 UTC 2021


On Tue, 29 Jun 2021 03:48:14 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> src/hotspot/share/utilities/resourceHash.hpp line 115:
>> 
>>> 113:   }
>>> 114: 
>>> 115:   unsigned size() const { return static_cast<const TABLE_IMPL*>(this)->size_impl(); }
>> 
>> I think size() should return the number of entries. The number of buckets should use a different name (assuming it needs to be publically accessible).
>
> In the latest version, I am following the same naming convention in hashtable.hpp:
> - table_size() = number of buckets
> - number_of_entries() = number of entries

Yes, please.

-------------

PR: https://git.openjdk.java.net/jdk/pull/4536


More information about the hotspot-dev mailing list