RFR: 8277372: Add getters for BOT and card table members [v2]

Thomas Schatzl tschatzl at openjdk.java.net
Mon Nov 29 16:55:08 UTC 2021


On Mon, 29 Nov 2021 12:58:58 GMT, Vishal Chand <duke at openjdk.java.net> wrote:

>> src/hotspot/share/gc/shared/blockOffsetTable.hpp line 56:
>> 
>>> 54:   static uint _LogN_words;
>>> 55:   static uint _N_bytes;
>>> 56:   static uint _N_words;
>> 
>> The `private` visibility modifier can be removed as this is default at the top of a class.
>> The static variables should start with a lower case letter after the underscore, something like `_log_n`.
>> 
>> My suggestion would also be to change `N`/`n` to something more understandable, like `size`, and add `block`, i.e. something like `_log_block_size`, `_log_block_size_in_words` similar to the corresponding `CardTable` members etc.
>> 
>> Edit: note that "block" isn't a good word to use here, so scratch that - "block" is any kind of area that is more generic than an object, but does not refer to the BOT entry.
>
> As I can understand, we need to replace "N" with something meaningful. Does something like "entry_size" or "bot_entry_size" would work?

I would think that `bot_entry_size` is one byte. Probably "bot_card_size"?

-------------

PR: https://git.openjdk.java.net/jdk/pull/6570


More information about the hotspot-dev mailing list