RFR: 8291714: Implement a Multi-Reader Single-Writer mutex for Hotspot
David Holmes
dholmes at openjdk.org
Fri Aug 12 04:48:17 UTC 2022
On Thu, 11 Aug 2022 15:18:10 GMT, Johan Sjölén <duke at openjdk.org> wrote:
> May I please have a review for this PR which implements a `MRWMutex` class for Hotspot?
>
> This PR does 3 things:
>
> * Adds a port of ZGC's MRSW mutex (see [0]) to Hotspot
> * Adds some new utilities for writing multi-threaded tests.
> * Adds some tests for MRSW Mutex using these new utilities
>
> The ticket has some comments which might be worth checking out: https://bugs.openjdk.org/browse/JDK-8291714
>
> [0] Original source code here: https://github.com/openjdk/zgc/blob/zgc_generational/src/hotspot/share/gc/z/zJNICritical.cpp
> Multi-Reader Single-Writer mutex
Sorry to bikeshed but such a thing is called a ReadWriteLock or a ReadersWriterLock or something similar - can we please use familiar nomenclature here (even rwlock as per POSIX). "mutex" is a contraction of mutual-exclusion and as readers are not mutually exclusive it is an oxymoron to talk about a "multi-reader mutex". Thanks.
-------------
PR: https://git.openjdk.org/jdk/pull/9838
More information about the hotspot-dev
mailing list