RFR: 8280136: Serial: Remove unnecessary use of ExpandHeap_lock

Kim Barrett kbarrett at openjdk.java.net
Thu Feb 10 03:14:05 UTC 2022


On Tue, 18 Jan 2022 12:03:46 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

> This PR consists of two commits:
> 
> 1. remove `ExpandHeap_lock` in Serial GC code.
> 2. rename it to `ParallelExpandHeap_lock` to indicate it's Parallel-GC only.
> 
> Test: tier1-6

I'm not keen on the suggested new name. I want to read ParallelExpandHeap_lock
as a lock for parallel expansion of the heap, which doesn't really have the
right flavor of subsystem ownership. I think (with this change) its uses are
limited to ParallelGC oldgen expansion, suggesting a name like
PSOldGenExpand_lock (or PSOldGen::Expand_lock, which could be private were it
not for the assert in MutableSpace and the "usual" practice of defining locks
in mutexLocker.[ch]pp).

Other than that naming issue, nice cleanup.

-------------

PR: https://git.openjdk.java.net/jdk/pull/7124


More information about the hotspot-dev mailing list