RFR: 8278282: G1: Log basic statistics for evacuation failure [v3]
Albert Mingkun Yang
ayang at openjdk.java.net
Mon Jan 3 20:37:18 UTC 2022
On Wed, 22 Dec 2021 02:33:37 GMT, Hamlin Li <mli at openjdk.org> wrote:
>> The original pr is at #6763 , which should be retired as we have decided to adjust part of optimization solution for evacuation failure (see #6627 for details), so the log will be adjusted accordiingly.
>> The basic log related to evacuation failed will looks like below based on this patch.
>>
>>
>> [13.126s][debug][gc,phases] GC(0) Restore Retained Regions (ms): Min: 0.0, Avg: 197.4, Max: 1579.1, Diff: 1579.1, Sum: 1579.1, Workers: 8
>> [13.126s][debug][gc,phases] GC(0) Evacuation Failure Regions: Min: 1, Avg: 1.0, Max: 1, Diff: 0, Sum: 1, Workers: 1
>
> Hamlin Li has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains three commits:
>
> - Merge branch 'master' into log-evac-failure-region-num
> - Fix test
> - Initial commit
Just a minor comment.
src/hotspot/share/gc/g1/g1GCPhaseTimes.cpp line 135:
> 133: _gc_par_phases[MergePSS]->create_thread_work_items("LAB Undo Waste", MergePSSLABUndoWasteBytes);
> 134:
> 135: _gc_par_phases[RestoreRetainedRegions]->create_thread_work_items("Evacuation Failure Regions:", RestoreRetainedRegionsNum);
Based on the surrounding naming conventions, `RestoreRetainedRegionsNum` should probably be sth like `RestoreRetainedRegionsNumEvacFailRegions` or just the suffix `NumEvacFailRegions`.
-------------
Marked as reviewed by ayang (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/6860
More information about the hotspot-dev
mailing list