RFR: 8265473: Move os::Linux to its own header file [v4]

Thomas Stuefe stuefe at openjdk.org
Sun Jul 10 04:41:43 UTC 2022


On Sat, 9 Jul 2022 23:27:31 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> Another step of moving unnecessary stuff outside of os.hpp
>> 
>> The `os::Linux` class is used only by the Linux-specific code in HotSpot. Therefore, it should be moved outside of os.hpp, which is used by platform-independent code.
>> 
>> I don't have a good name for the new header. `os_linux.hpp` would have been a good name, but that's already taken, so I am settling on os_linux.impl.hpp. Suggestions are welcome.
>
> Ioi Lam has updated the pull request incrementally with one additional commit since the last revision:
> 
>   renamed to os_linux_impl.hpp

I'm surprised that this works. That you are able to declare a nested class outside its enclosing class.

Apart from that, seeing that this has nothing really to do anymore with os::, why not just drop the "os::" prefix? Just call it "Linux" or "LinuxImpl" or "LinuxHelpers" or "LinuxOsHelpers" ...

-------------

PR: https://git.openjdk.org/jdk/pull/9423


More information about the hotspot-dev mailing list