Integrated: 8295016: Make the arraycopy_epilogue signature consistent with its usage
Zixian Cai
duke at openjdk.org
Tue Oct 18 00:56:12 UTC 2022
On Sat, 8 Oct 2022 06:06:25 GMT, Zixian Cai <duke at openjdk.org> wrote:
> The second register argument should be named `count`. Please see the following usage.
>
> https://github.com/openjdk/jdk/blob/495c043533d68106e07721b2e971006e9eba97e3/src/hotspot/cpu/riscv/stubGenerator_riscv.cpp#L1138
>
> https://github.com/openjdk/jdk/blob/495c043533d68106e07721b2e971006e9eba97e3/src/hotspot/cpu/riscv/stubGenerator_riscv.cpp#L1210
>
> https://github.com/openjdk/jdk/blob/495c043533d68106e07721b2e971006e9eba97e3/src/hotspot/cpu/riscv/stubGenerator_riscv.cpp#L1584
>
> Update: also fix for AArch64.
This pull request has now been integrated.
Changeset: 692cdab2
Author: Zixian Cai <u5937495 at anu.edu.au>
Committer: Fei Yang <fyang at openjdk.org>
URL: https://git.openjdk.org/jdk/commit/692cdab2be7dfc6e12b127f8e2c97bc41536cb84
Stats: 2 lines in 2 files changed: 0 ins; 0 del; 2 mod
8295016: Make the arraycopy_epilogue signature consistent with its usage
Reviewed-by: shade
-------------
PR: https://git.openjdk.org/jdk/pull/10620
More information about the hotspot-dev
mailing list