RFR: 8293566: RISC-V: Clean up push and pop registers [v3]

Feilong Jiang fjiang at openjdk.org
Sun Sep 11 02:17:38 UTC 2022


> Currently, riscv port has two implementations of `push_reg` and `pop_reg`.
> The bitset version can be replaced with the RegSet version for better readability.
> 
> For example, if we want to push x10 and x11, pushing register with bitset would be like:
> 
> push_reg(0xc00, sp)
> 
> 
> while pushing register with RegSet will be more clear:
> 
> push_reg(RegSet::of(x10, x11), sp);
> 
> 
> Testing:
> 
> - hotspot and jdk ter1 on QEMU without new failures

Feilong Jiang has updated the pull request incrementally with one additional commit since the last revision:

  fix return size of push_v/pop_v

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/10227/files
  - new: https://git.openjdk.org/jdk/pull/10227/files/441d50c6..5dd1c9ef

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=10227&range=02
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=10227&range=01-02

  Stats: 2 lines in 1 file changed: 0 ins; 0 del; 2 mod
  Patch: https://git.openjdk.org/jdk/pull/10227.diff
  Fetch: git fetch https://git.openjdk.org/jdk pull/10227/head:pull/10227

PR: https://git.openjdk.org/jdk/pull/10227


More information about the hotspot-dev mailing list