RFR: 8256265: G1: Improve parallelism in regions that failed evacuation [v6]
Albert Mingkun Yang
ayang at openjdk.org
Wed Sep 14 11:22:55 UTC 2022
On Wed, 14 Sep 2022 10:55:50 GMT, Thomas Schatzl <tschatzl at openjdk.org> wrote:
>> Hi all,
>>
>> can I have reviews on this change that makes the evacuation failure remove forwards phase split the work across threads within regions?
>>
>> This work is a continuation of PR#7047 from @Hamlin-Li and latest improvements from @albertnetymk in that thread. This is reflected in the first commit, I added a fair amount of changes to fix bugs and streamline the code.
>>
>> Testing: tier1-8 with G1EvacuationFailureALot enabled, tier1-5 as is
>
> Thomas Schatzl has updated the pull request incrementally with one additional commit since the last revision:
>
> sjohanss, ayang review 4
Just some minor comments.
src/hotspot/share/gc/g1/g1EvacFailure.cpp line 209:
> 207: }
> 208:
> 209: void G1RemoveSelfForwardsTask::initialize() {
Any particular reason why this is not part of the constructor?
src/hotspot/share/gc/g1/g1YoungGCPostEvacuateTasks.cpp line 117:
> 115:
> 116: double chunks_per_thread = (double)G1CollectedHeap::get_chunks_per_region() / G1RestoreRetainedRegionChunksPerWorker;
> 117: return chunks_per_thread * _evac_failure_regions->num_regions_failed_evacuation();
The calculation is correct, but the var name is wrong.
`chunks/region / chunks/worker == workers/region` then `workers/region * region == workers`. This method returns the optimal number of workers.
(PS: I still think doing multiplication is easier to reason, but that can be subjective.)
-------------
Marked as reviewed by ayang (Reviewer).
PR: https://git.openjdk.org/jdk/pull/9980
More information about the hotspot-dev
mailing list