Integrated: 8294430: RISC-V: Small refactoring for movptr_with_offset

Fei Yang fyang at openjdk.org
Wed Sep 28 00:26:09 UTC 2022


On Tue, 27 Sep 2022 07:20:11 GMT, Fei Yang <fyang at openjdk.org> wrote:

> The name of function 'movptr_with_offset' looks misleading. It actually returns an offset to its caller.
> We could rename this function to 'movptr' so that it overloads existing function 'movptr'.
> 
> 
>    void movptr(Register Rd, address addr);
> - void movptr_with_offset(Register Rd, address addr, int32_t &offset);
> + void movptr(Register Rd, address addr, int32_t &offset);
> 
> 
> Testing: Tier1 hotspot on HiFive Linux-riscv64 Unmatched board.

This pull request has now been integrated.

Changeset: d827fd83
Author:    Fei Yang <fyang at openjdk.org>
URL:       https://git.openjdk.org/jdk/commit/d827fd830afda58e30b667e61fc4653423db9d39
Stats:     28 lines in 10 files changed: 0 ins; 2 del; 26 mod

8294430: RISC-V: Small refactoring for movptr_with_offset

Reviewed-by: fjiang, yadongwang, shade

-------------

PR: https://git.openjdk.org/jdk/pull/10439


More information about the hotspot-dev mailing list