RFR: 8307352: AARCH64: Improve itable_stub [v2]

Boris Ulasevich bulasevich at openjdk.org
Mon Aug 7 08:15:38 UTC 2023


On Wed, 19 Jul 2023 09:08:33 GMT, Evgeny Astigeevich <eastigeevich at openjdk.org> wrote:

>> Boris Ulasevich has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains one additional commit since the last revision:
>> 
>>   8307352: AARCH64: Improve itable_stub
>
> src/hotspot/cpu/aarch64/macroAssembler_aarch64.cpp line 1221:
> 
>> 1219:   int scan_step = itableOffsetEntry::size() * wordSize;
>> 1220:   int vte_size = vtableEntry::size_in_bytes();
>> 1221:   int ioffset = in_bytes(itableOffsetEntry::interface_offset());
> 
> `itoentry_interface_offset`?

The correct explicit name would be itable_offset_entry_interface_offset, which I think is hard to read. if you don't mind, let us keep the short name for this case:

  int vtable_start_offset = in_bytes(Klass::vtable_start_offset());
  int itable_offset_entry_size = itableOffsetEntry::size() * wordSize;
  int ioffset = in_bytes(itableOffsetEntry::interface_offset());
  int ooffset = in_bytes(itableOffsetEntry::offset_offset());

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/13792#discussion_r1285531028


More information about the hotspot-dev mailing list