RFR: 8307352: AARCH64: Improve itable_stub [v8]

Boris Ulasevich bulasevich at openjdk.org
Mon Aug 28 13:14:43 UTC 2023


On Sat, 26 Aug 2023 20:51:26 GMT, Evgeny Astigeevich <eastigeevich at openjdk.org> wrote:

>> Boris Ulasevich has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Comments applied: get rid of temp_reg3; replace the magic constants
>
> src/hotspot/cpu/aarch64/macroAssembler_aarch64.cpp line 1297:
> 
>> 1295:   bind(L_holder_found);
>> 1296:   ldrw(method_result, Address(scan_temp, ooffset - ioffset));
>> 1297:   add(recv_klass, recv_klass, (itable_index << LogBytesPerWord) + in_bytes(itableMethodEntry::method_offset()) - vtable_start_offset - ioffset);
> 
> Maybe use `itable_index * wordSize` instead of `itable_index << LogBytesPerWord` to look the same as in the x86 variant of `lookup_interface_method_stub`. 
> Also a comment that `- vtable_start_offset - ioffset` is used to restore the original value of `recv_klass` would be useful.

Ok. Thanks!

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/13792#discussion_r1307404253


More information about the hotspot-dev mailing list