RFR: 8301992: Embed SymbolTable CHT node
Calvin Cheung
ccheung at openjdk.org
Wed Feb 15 16:11:19 UTC 2023
On Wed, 15 Feb 2023 13:41:20 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
>> The name of the `heap` parameter to this function should be changed. The node, which contains the Symbol, is always C_HEAP allocated. I would suggest renaming it to `is_permanent`. Same for the other functions that have a `heap` parameter.
>
> If the symbol is permanent, it's allocated to an arena not C heap but I agree that the variable name should be changed.
> There's a version of NEW_RESOURCE_ARRAY that takes the Thread argument, so it doesn't have to call Thread::current()
I've changed it to:
`u1* u1_buf = NEW_RESOURCE_ARRAY_IN_THREAD(current, u1, alloc_size);`
-------------
PR: https://git.openjdk.org/jdk/pull/12562
More information about the hotspot-dev
mailing list