RFR: 8309408: Thread.sleep cleanup
Alan Bateman
alanb at openjdk.org
Mon Jun 5 06:19:27 UTC 2023
Thread.sleep has had quite a bit of churn recently to support virtual threads, add sleep(Duration), a JFR event, and the change the underlying implementation to support sub-millis precision. I think the changes have settled down now so we can do some small cleanups that came up in PR discussions. The cleanups were kicked down the road as it requires tracking down faraway tests that depend on the stack depth and the names of internal methods. The two cleanups proposed here are:
1. Add a private sleepNanos method that creates/commits the JFR event around the sleep, this avoids duplicate code in the 3 sleep methods.
2. Rename JVM_Sleep to JVM_SleepNanos to make it clear that it takes the sleep time in nanoseconds, esp. when Thread.sleep's parameter is milliseconds.
-------------
Commit messages:
- Initial commit
Changes: https://git.openjdk.org/jdk/pull/14303/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=14303&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8309408
Stats: 75 lines in 10 files changed: 27 ins; 32 del; 16 mod
Patch: https://git.openjdk.org/jdk/pull/14303.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/14303/head:pull/14303
PR: https://git.openjdk.org/jdk/pull/14303
More information about the hotspot-dev
mailing list