RFR: 8310160: Make GC APIs for handling archive heap objects agnostic of GC policy [v2]

Ashutosh Mehra duke at openjdk.org
Tue Jun 20 15:02:06 UTC 2023


On Tue, 20 Jun 2023 09:22:46 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:

>> Ashutosh Mehra has updated the pull request incrementally with three additional commits since the last revision:
>> 
>>  - Remove unnecessary assert and condition for UseG1GC
>>    
>>    Signed-off-by: Ashutosh Mehra <asmehra at redhat.com>
>>  - Rename CollectedHeap::reserved() to CollectedHeap::reserved_range()
>>    
>>    Signed-off-by: Ashutosh Mehra <asmehra at redhat.com>
>>  - Rename alloc_archive_space to allocate_archive_space
>>    
>>    Signed-off-by: Ashutosh Mehra <asmehra at redhat.com>
>
> src/hotspot/share/gc/shared/collectedHeap.hpp line 212:
> 
>> 210:   MemRegion reserved_region() const {
>> 211:     return _reserved;
>> 212:   }
> 
> Could you extract out this (a new CollectedHeap API) to its own ticket/PR? (It seems important enough to not be hidden inside a CDS PR.)

Sure. I will open an issue and PR for this.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/14520#discussion_r1235401957


More information about the hotspot-dev mailing list