RFR: 8310906: Fix -Wconversion warnings in runtime, oops and some code header files. [v4]

Coleen Phillimore coleenp at openjdk.org
Wed Jun 28 19:48:30 UTC 2023


On Wed, 28 Jun 2023 16:15:39 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> Coleen Phillimore has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Use pointer_delta_as_int for the name that uses pointer_delta, fix negative case to just do checked_cast.
>
> src/hotspot/share/utilities/globalDefinitions.hpp line 529:
> 
>> 527: template <typename T>
>> 528: inline int pointer_delta_as_int(const volatile T* left, const volatile T* right) {
>> 529:   return checked_cast<int>(pointer_delta(left, right, sizeof(T)));
> 
> For clarity, I think you should add a comment saying the returned value is always non-negative.

done, thanks!

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/14675#discussion_r1245681394


More information about the hotspot-dev mailing list