RFR: 8303418: Improve parameter and variable names in BitMap

Kim Barrett kbarrett at openjdk.org
Wed Mar 1 04:46:53 UTC 2023


Please review this change to names in BitMap.

- Parameters that designate a bit in a BitMap are named "bit".
- Parameters that designate a word in the underlying BitMap storage are named "word".
- Parameters that designate a range are named "beg" and "end" resp.

Added helper function `flipped_word` for use by `get_next_bit_impl`, replacing
the odd overload for `map`.

In `get_next_bit_impl`, prefixed the variables "index" and "limit" with
"word_" to make clear the units.

Testing:
mach5 tier1

-------------

Commit messages:
 - improve names in get_next_bit_impl
 - cleanup parameter names

Changes: https://git.openjdk.org/jdk/pull/12798/files
 Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=12798&range=00
  Issue: https://bugs.openjdk.org/browse/JDK-8303418
  Stats: 53 lines in 3 files changed: 5 ins; 1 del; 47 mod
  Patch: https://git.openjdk.org/jdk/pull/12798.diff
  Fetch: git fetch https://git.openjdk.org/jdk pull/12798/head:pull/12798

PR: https://git.openjdk.org/jdk/pull/12798


More information about the hotspot-dev mailing list