RFR: 8307806: Rename Atomic::fetch_and_add and friends [v3]

David Holmes dholmes at openjdk.org
Sat May 13 21:37:55 UTC 2023


On Fri, 12 May 2023 09:00:49 GMT, Kim Barrett <kbarrett at openjdk.org> wrote:

>> Please review this renaming of Atomic::fetch_and_add and friends to be
>> consistent with the naming convention recently chosen for atomic bitops.  That
>> is, make the following name changes for class Atomic and it's implementation:
>> 
>> - fetch_and_add => fetch_then_add
>> - add_and_fetch => add_then_fetch
>> 
>> Testing:
>> mach5 tier1-3
>> GHA testing
>
> Kim Barrett has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains six commits:
> 
>  - additional renamings post-genzgc
>  - Merge branch 'master' into atomic-arith-names
>  - revert accidental Red Hat copyright change
>  - rename in tests
>  - rename uses
>  - rename impl

src/hotspot/share/gc/z/zRelocationSet.cpp line 47:

> 45:   const ZArray<ZPage*>*          _small;
> 46:   const ZArray<ZPage*>*          _medium;
> 47:   ZArrayParallelIterator<ZPage*> _small_iter;

Why was this removed?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/13896#discussion_r1193039772


More information about the hotspot-dev mailing list