RFR: 8319781: RISC-V: Refactor UseRVV related checks
Fei Yang
fyang at openjdk.org
Mon Nov 13 14:49:59 UTC 2023
On Thu, 9 Nov 2023 10:30:41 GMT, Hamlin Li <mli at openjdk.org> wrote:
> Hi,
> Can you review the patch to refactor the code related UseRVV checks?
> Thanks!
>
> There are some code (flag setting/checking) depending on UseRVV's value, these code should be refactored, especially after the change of https://bugs.openjdk.org/browse/JDK-8319408:
> 1. some code needs to get the final UseRVV's value rather than the initial value, e.g. ChaCha20 intrinsic.
> 2. refactored to be more readable.
> 3. also add note to make sure the future code get the final UseRVV value instead of inital value.
Changes requested by fyang (Reviewer).
src/hotspot/cpu/riscv/vm_version_riscv.cpp line 295:
> 293:
> 294: if (!UseRVV) {
> 295: FLAG_SET_DEFAULT(SpecialEncodeISOArray, false);
Could you please remove this line while you are on it? I don't think we need to reset `SpecialEncodeISOArray` here.
-------------
PR Review: https://git.openjdk.org/jdk/pull/16580#pullrequestreview-1727476994
PR Review Comment: https://git.openjdk.org/jdk/pull/16580#discussion_r1391214061
More information about the hotspot-dev
mailing list